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Preface 
 
This user manual explains all the functions provided by Sunmaster-Monitor. It is meant to 
offer you a quick and easy introduction to the application. 
 
Sunmaster-Monitor has been developed for the visualization of your measured values. It 
does not offer you an automatic fault analysis or alarm messages. 
 
This documentation is copyrighted. All rights reserved, especially the right to reproduction 
and distribution. 
Errors and omissions are excepted. Both documentation and program are subject to 
change without prior notice.  
 

1 Purpose of User Manual 

This user manual applies to interested Sunmaster-Monitor end customers. It is aimed at 
guiding the user from the installation to the visualization of the measuring data. It gives 
explanations on all the user interface functions and all the menu items and exemplifies 
step-by-step how to use them. 
 

2 Components and Accessories 

Software: 
On the installation CD you will find the Sunmaster-Monitor program for installation as well 
as the following additional information: 

• User manual on how to operate the data logger 
• Hardware connection diagrams and installation guidelines. 
• Brochures 

 
Hardware: 
The following components are required for starting up the hardware: 
Local version: 

• Data logger with Ethernet interface 
• Cross cable for direct communication with a PC 
• Patch cable for integration into your intranet 

 
or Modem type: 

• Data logger with integrated modem 
• Telephone cable from the data logger to your telephone socket 
• Modem for the PC used to run the Sunmaster-Monitor   
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3 Software Installation 

3.1 System Requirements 
 
 General: 
Processor with at least 1 GHz 
RAM 256 MB 
Hard disk with at least 50 MB of free memory 
Microsoft® Windows® 98 / ME / 2000 / XP 
 
Local version: 
Network interface card with Ethernet port (100 Mbit) 
 
Modem type: 
Depending on the data logger: analog or ISDN Modem 
 
Note: Please keep in mind that the longer you use the program the more memory space 
will be required on the hard disk, as the program files the data recorded by the data logger 
in a data base. 

3.2 Installation 
 
The first steps 
Put the installation CD into your computer’s CD drive. 
 
Under Windows, the installation manager will start automatically. If this is not the case, 
please open the file manager and click the drive letter of the CD drive. Doubleclick 
Sunmaster-MonitorSetup.exe. 
 
You need administration rights in order to install the program. 
 
The installation will be started now automatically. 
 
The Sunmaster-Monitor installation program will appear. Follow the instructions on the 
screen and click Continue. 
 
After all files have been copied to the hard disk a program group will be created. The 
installation is completed now. Some operating systems restart the computer after the 
installation. Later you can open the program anytime via the Windows start menu.  
 
Network Connection Set-Up: 
For direct connection between the data logger and your PC please use a network interface 
card. Normally this network interface card is already integrated in new systems. 
 
To set up your network interface card, please go to: System Settings > Network 
connections.  
 
Click on Network Connections; a new window will appear displaying your network 
connections. Select Local Area Connection by double-clicking on the icon. 
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The following dialogue will open: 
 

       
 
Please select Internet Protocol (TCP/IP) and click on the Properties button. The settings 
of your network interface card will be displayed here. Please configure your network 
according to the example shown above. 
 
Please note: The IP address of your network interface card and the IP address of your 
data logger must not be identical. Example: 
 
IP address of the network interface card:  192.168.30.1 
IP address of the data logger:  192.168.30.40 
 
 
Setting up an RDT connection 
 
In this manual, the connection via RDT is only mentioned as an option. Please find 
detailed information on how to establish an RDT connection in the installation guidelines 
for the data logger. 
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3.3 Application Registration 
 
If you start the program for the first time, the Registration dialogue will be shown. The 
serial number of the data logger has to be entered for the registration. You will find the 
serial number on the casing of the device. 
 

 
 
Please make sure the number is in the correct format. The serial number is divided into 
three blocks that are separated by blanks. Please enter the three blocks into the 
corresponding input fields.  
 
Example:   300645 0406 001 
 
Click the Register button afterwards. If the registration was successful, click Continue. 
The dialogue Set up new system will be opened. 
 

4  Configuration   

4.1 Set up a New System 
After you have successfully registered the program you will be asked to enter the system 
parameters. Here, you enter a designation for the PV system as well as the installed 
power and the area. These parameters will be used for future calculations. 
 



Sunmaster-Monitor  User Manual 
 

- 7 - 

 
Click the Save button. 
Afterwards the view of the new system will be presented. 
 
Please note:  
The parameters “Designation”, “Power” and “Area” can later be modified via the Edit > System 
Parameters menu.  
 

4.2 Connection Settings 
Open the dialogue Establish Direct Connection via the File > Connection Settings 
menu. 
 

 
 
Select the type of your connection in the list next to Connection via. 
 
Direct communication: „Network“ 
Modem communication: “Name of RDT connection” 
 
Please note: 
If the communication is effected via modem, the RDT connection must have been established and 
tested independently of the Sunmaster-Monitor program in advance. 
 
In the Target Directory, the recalled measuring data will be stored. In this way, the data 
will be available as backup and raw data. 
You can change the target directory via the button next to the path name. 
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If you do not need the measured value files any further, the program can delete them after 
they have been imported. For this option, set the checkmark next to Delete measured 
value files after import. You only need the files if you wish to archive this raw data. The 
program does not require the files after they have been imported. 
 
The IP address and the IP address of the data logger must be the same. Unless you have 
altered them, the default settings for the IP address are as follows:   
 
Direct communication: 192.168.30.40 
or 
Modem communication: 192.168.200.1 
 
For the direct connection it is required to enter the User name and the Password, too. 
The default values are as follows: 
User name:  admin 
Password:   admin 
 
Click Save in order to accept the entry and close the dialogue. 

4.3 Recall Data 
After you have completed all the settings you can import the measured values by clicking 
File > Recall data. The following dialogue will be shown: 
 

 
 
Next to Status you can check whether the connection to the data logger has been 
established. If you use a network connection, the status should always read “Connected”. 
If you use an RDT connection, this is only the case after the connection has successfully 
been established. 
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Select the year and the month first.  After that, select the days you wish to import from the 
Missing days list. If you hold down the Shift key you can select several days at a time. 
Click > then in order to transfer the selected days to the Days to be recalled window. Use 
< to undo this process. 
 
In the Missing days window the days which have not been recalled yet are displayed. If 
you put a checkmark in front of Show all the days of a month, the days that have already 
been recalled are shown, too. In addition you will be shown how many measuring points 
are available or whether there is no data at all. 
 
Click Request data to set up the connection. You can watch the transmission and the data 
import in the status window. The following status messages are shown: 
 
 Status Description 
Setting up connection. The connection to the device is being 

prepared (RDT). 
Connection “X”  The connection (RDT) is being set up. 
Connection “X” has been set up. The net connection has been established. 

(RDT) 
Setting up FTP connection. The FTP connection is being set up 

according to the connection options. 
The files for the date “X” are being copied 
to the directory “X”. 

The measured value files are being copied 
and stored in the target directory. 

Disconnecting FTP connection. The copying has been completed now. 
Importing data The connection to the data logger has been 

closed, the copied files are being imported. 
Importing directory “X”  The content of the stated directory is being 

imported. 
Process finished The import has been completed  The 

window can be closed. 
 
While the connection is being set up or while data is being copied, certain errors can 
occur. Some of the errors are listed in the following table: 
 
Error message Reason 
The computer is currently in offline mode 
and cannot be set online. The transmission 
cannot be initiated. 

If you use the Internet Explorer to view web 
pages, it might be possible that your PC is 
in the so-called “off-line mode”. The 
computer tries to load the requested web 
pages from the local memory. This 
functionality can lead to failures while the 
connection to the data logger is being set 
up. 

The latest request is still being processed. An internal error has occurred during the 
FTP transfer. Close the connection and try 
again. 

The connection to the remote host cannot 
be established. 

Maybe the connection settings are not 
correct. This concerns the IP address as 
well as the user information. 

The user name has been refused by the 
data logger. 

Please check the settings under 
Connection Settings.  The entered user 
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name has not been accepted. 
The password has been refused. Please check the settings under 

Connection Settings.  The entered 
password has not been accepted. 

The data logger cannot be accessed via the 
indicated IP address (xxx.xxx.xxx.xxx). 

Please check the settings under 
Connection Settings.  The data logger 
cannot be accessed via the indicated IP 
address (xxx.xxx.xxx.xxx). 

 

4.4 Import of Measured Values 
 
In addition to being able to recall the measured data from the data logger memory you can 
also import data from the hard drive of your Computer or via the portable memory card of 
the data logger. This function is useful if you cannot establish a connection between data 
logger and computer. 
 
If you want to import single files, click File > Import > File(s). Afterwards, select the 
desired files in the Open dialogue and click Open in order to start the import of the 
measured data. 
 

 
   
 
Transfer of measured data via memory card 
 
If you use this function, please consider the following points:  

• The data logger is to be separated from the net before the memory card is taken 
out. If you take out the memory card during operation it can be destroyed! 

• The card is on the right hand side of the data logger. 
• It is recommended to use a small screwdriver to take the card out. 
• Put the card into your card reader. 
• Choose the menu item File > Import > Directory to open the Browse for Folder 

dialog. 
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• Select the drive letter of your card reader and afterwards the “Data” directory. 
• Click OK in order to start the import of the measured data.  
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4.5 Defining the Feed-in Meter 
The energy yield of your PV system can be determined in different ways. Click the menu 
option Edit > Feed-in Meter to open the dialogue Define the feed-in meter. Here you can 
define how the total energy yield of your PV system is to be determined. The following 
options are available: 
 

- Measured Values: The feed-in meter is made up of different measured 
values. Select the corresponding value(s) in the selection window. 

- Inverters: The feed-in meter is built using the inverters’ measured values. 
- Not available: There is no measured value to be used for the feed-in meter. 
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5 Display of Measured Values 

5.1 Day Graph 
The menu option Day provides the following view: 
 

 
 
In the left part of the window, choose your PV system under PV System(s) first. Under 
Measured Value Period you are shown the period for which the database contains 
measured data. Under Selection of Date use the calendar function or the arrow buttons 
<<, >> to select the desired date. After the data have been imported the current day will 
automatically be displayed.  
 
You can choose between the options Standard and Inverter.  
 
Standard 

The measured values which are available by default will be displayed here. If you 
put a checkmark in the box for the desired Measured Value, the data will be 
displayed in the diagram. 
 

Inverter 
Put a checkmark for the desired Measured Value and the Address of the inverter 
in order to display the data.Under Colour Distinction you can define whether the 
measured values or the inverters are to be distinguished by different colours. 
 
For the inverters only daily values are available, so the menu options Month and Year will 
be deactivated if you choose Inverter. 
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In the legend below the diagram the measured values are assigned the corresponding 
colours. 
Display single measured values: 
If you move the cursor slowly over the graph, the measured values will be displayed next 
to the cursor together with their numerical value and unit. 
 

5.2 Month Graph 
The menu option Month provides the following view: 
 

 
 
First select the desired month in the left part of the window under Selection of Date, 
afterwards select the type of value that you want to be displayed under Measured Value. 
 
Display single measured values: 
If you move the cursor over the bars slowly, the measured values will be displayed next to 
the cursor together with their numerical value and unit. 
 
In addition, the total sum of the chosen month and the entire year is displayed above the 
graph. 
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5.3 Year Graph  
The menu option Year provides the following view: 
 

 
 
First select the desired year in the left part of the window under Selection of Date, 
afterwards select the type of value that you want to be displayed under Measured Value. 
 
Display single measured values: 
If you move the cursor over the bars slowly, the measured values will be displayed next to 
the cursor together with their numerical value and unit. 
 
The sum of the chosen year and the total sum since data acquisition was started are 
displayed above the graph as a numerical value. 
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5.4 Live Values 
If you click the Live Values menu item you can choose between the view options Survey 
and Detail. 
 
Survey 
 

 
 
In this view, current data such as irradiance, power and total energy yield are displayed. 
Irradiance data is only displayed if an irradiance sensor is available and if the sensor is 
connected to the first analog input of the data logger. 
 
Detail 
 

 
 
In this view, a table containing inverter data will be displayed. This function is only 
available if inverters have been connected to the data logger and if the data logger is 
equipped with the latest software. 
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If the connection to the data logger is effected via the local network, the connection is 
already established: the progress bar will let you know when the display is being 
refreshed. If you use a modem connection, the connection to the data logger has to be 
established first. 
Since the Detail view requires information on the number and the addresses of the 
connected inverters, it is necessary to import measured data before using this function. 
 

5.5 Printing and Saving a Diagram 
Click the Graph > Print menu item to print the displayed diagram. 
 
If you click the Graph > Save menu item you can save the diagram as an image file and 
make it available for integration into other programs. 
 
Please note:  
The Print and Save functions are not available for the Live Values. 
 

6 Additional Functions 

6.1 Displaying Calculated Values 
The “Sunmaster-Monitor” program automatically calculates a number of further values 
from the available measured values. 
If, for example, the energy yield is not acquired directly via an energy meter, but the 
energy of the individual inverters is transferred, the total sum can be calculated.  
 
Click the Edit > Measured Value Display menu item in order to open the following 
dialogue:  
 

 
 
Here you can select which calculated values are to be displayed in the diagrams by putting 
a checkmark in front of the corresponding entry.  
If you want to do without a certain calculated value, remove the checkmark from the 
corresponding entry. These settings can be changed at any time. 
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6.2 Recalculation of Measured Values 
Under the menu item Edit > Recalculation values can be recalculated for a certain period. 
 

 
 
This is only required if power or area have been adjusted belatedly and if measured values 
are displayed which are based on it, such as irradiance energy or efficiency. Choose the 
period for which the values are to be recalculated first. Click the button Start recalculation 
afterwards. If the calculation is done, click Close. 
 

6.3 Setting up a New System 
Select the menu item File > New System in order to set up a new system. 
 
Proceed just like you did when setting up the first system. If you set up another system you 
need to enter a registration number as well. Use the serial number of your data logger as 
your registration key – just like when you set up the first system. 
 
The selection of the two different systems is done via the selection list PV System(s). 
 

6.4 Deleting a System 
Under File > Delete System you can completely remove a system from the program. The 
currently selected system will be deleted, all the data stored in the data base of the 
corresponding system will be removed.   
An additional dialogue will prevent you from deleting the system unintentionally. 
 

6.5 Changing the Language 
Under the menu item Language you can choose between the languages German and 
English. 
 

6.6 Program Update 
If you click the ? > Program update menu item you can check whether a later version of 
the program is available.  In this case you can download the new version via a link. This 
requires Internet access. 
 



Sunmaster-Monitor  User Manual 
 

- 19 - 

6.7 Version Information 
The menu item ? > Information provides you with information on the version of the 
program you are using. 
 

7 Troubleshooting 

 
Registration not successful 
 
If you should experience problems when registering, the following reasons might 
considered: 

- The registration key is invalid (typing error). 
- The same key has already been used for another system. 

 
 
Data import not successful 
 
If the data import was not successful you might consider the following reasons: 

- The file format is invalid. 
- An error has occurred during the transfer. 
- The connected inverter is not supported. 

 
 
Connection between designation of measured value, abbreviation and 
representation 
 
The abbreviation of a measured value is used in tables, lists and diagrams in order to 
make the masks clearer and more concise. The designation of a measured value 
describes the function that the measured value has within the system, e.g. feed-in meter. 


